Posts tagged ‘Seagate’

Replacement Seagate drive arrives

The replacement Seagate drive arrived earlier today. It appears the RMA process is pretty painless and works very well.

Replacement drive shows up as having the same period of warranty remaining, so all good. The interesting thing to note on the new drive is the label, I’ll take a photo tonight and post it on this entry. Basically the label indicates the drive was reworked.

Now I just need to buy an external case to make use of it, since it was replaced with a Samsung 500GB almost immediately when it died. So no external case available any more to use the Seagate in.

Faulty Seagate drive – returned

Filled out the RMA form online with Seagate and printed out RMA slip. Just sent the drive back for replacement.

We’ll see how long it takes to be replaced.

Drive Failure

It would appear the Seagate 320Gb drive I’ve been using in an external case decided to start giving some errors. It ONLY started to happen once the drive got certain capacity. Lost a number of days of recorded TV as the drive is used as my recording drive for my Mac Mini.

Ran Seatools over the drive it has about 90+ LBA surface errors. Repair completes, but short test fails again with a new one. Looks as though it is terminal. I managed to pull most data off the drive, but the recorded programs in the section of the LBA surface errors would not be obtainable. Oh well.

Replaced it with a Samsung 500Gb drive which I purchased yesterday. This new drive is SO quiet, not to mention very well priced.