Month: March 2016

Windows Preview – Running Bash on Ubuntu on Windows

This is something that hit the news in the last 24 or so hours and is a in my opinion a game changer. I expect this will have significant impact in the way a lot people might work.

Just click the image below to be redirected to the site/video.

20160331-running-bash-on-ubuntu-on-windows-300x169

I’ll admit, I would probably configure this myself on my Windows 10 computer(s) if and when it becomes available.

Badlock Bug – Get ready for patching

Saw an announcement for Badlock Bug.

On April 12th, 2016, a crucial security bug in Windows and Samba will be disclosed. We call it: Badlock.

Engineers at Microsoft and the Samba Team are working together to get this problem fixed. Patches will be released on April 12th.

Admins and all of you responsible for Windows or Samba server infrastructure: Mark the date. (Again: It’s April 12th, 2016.)

Please get yourself ready to patch all systems on this day. We are pretty sure that there will be exploits soon after we publish all relevant information.

Guess we should get ready for patching of systems on April 12th, 2016.

Site Decisions and Direction

Up until earlier today I was generating this site using Jekyll (PortableJekyll to be precise).

I really do love Jekyll, however I found that my workflow didn’t work so well and that sometimes I just want to push out a post while not having any direct access to the machine where the PortableJekyll installation existed.

As such I made to decision to move site back to WordPress. However, Disqus is and will continue to be used for the Comments engine. As I expect this will help cut down on significant comment spam.

Jekyll is an awesome product and will continue to be so, however WordPress as much as I dislike it sometimes, just fits my usage and allows me to publish out content very quickly no matter where I am.

Happy Easter

Happy Easter everyone.

I love chocolate like most people, however even I took it easy and didn’t eat much at all. Unfortunately chocolate and trying to loose weight doesn’t go really well together.

I am going to eat my chocolate eggs with some self control. I hope everyone had a lovely day and spent time with family on this special day.

New Freeware from GRC: Never10

Came across a handy utility called “Never10”. It was announced on Twitter here.

Tiny (82k) utility allows easy disable or re-enable of Windows 7/8 OS upgrade to Windows 10.

20160326-grc-never10

 

Very handy, no need to set the registry key manually to disable GWX any more.

Setting up Mikrotik RouterBoard with USB Mobile Broadband Dongle

On the account I won a Mikrotik hAP-2nD from Duxtel, see post here. I thought it might be a good idea to see if I could get this unit to work with a Telstra 4G USB Mobile Broadband Dongle.

Initially I had some problems, however, you shouldn’t do things when tired. Eventually I worked out where I had went wrong and got things to work after all.

First I had to set the following in Winbox Terminal;

/port firmware set directory=firmware ignore-directip-modem=yes

After I reboot the router, my device showed up as being connected to USB1. Which is what is needed for the next step.

Mikrotik should configure a PPP interface automatically, as such you will need to tweak it to match what your needs are. Those settings below are what I am using for my Telstra dongle in question. I modified the name of my interface to suit my environment.

name="ppp-out2" max-mtu=1500 max-mru=1500 mrru=disabled port=usb1 
      data-channel=3 info-channel=2 apn="telstra.internet" pin="" user="" 
      password="" profile=default phone="" dial-command="ATDT" modem-init="" 
      null-modem=no dial-on-demand=yes add-default-route=yes 
      default-route-distance=0 use-peer-dns=yes keepalive-timeout=30 
      allow=pap,chap,mschap1,mschap2

Finally step was to setup a NAT rule to use the new out interface.

/ip firewall nat
add action=masquerade chain=srcnat comment="masquerade for ppp-out2 (dongle)" 
    out-interface=ppp-out2

Once this was all done, it worked fine. Very impressed.

Unit pictured below configured and running with Telstra 4G dongle plugged in.

Duxtel Mikrotik Monday Hardware Arrives

The #mikrotikmonday hardware I won from Duxtel arrived yesterday, however I wasn’t able to make it to post office until today.

Still very happy with the win of this router, it will certainly come in handy for something I want to perform.

Will give me the opportunity to configure the USB port with a Mobile Broadband Dongle and understand how to configure it. Without messing up my own existing Mikrotik RouterBoard which I use for my internet connectivity already.

duxtel-mikrotikmonday-hardware-arrives

 

New Hardware – DNTV Dual Hybrid 7164 PCIe DVB-T Card

Recently been having some problems with one of two TiVo’s that we own. Looks like its probably terminal, as such need to come up with a solution for FTA recordings my wife does.

After discovering DVBLink from DVBLogic I thought it might be a good idea to get a good internal Dual Tuner for my recently rebuilt desktop computer.

Anyways decided to bite the bullet and ordered a DNTV Dual Hybrid (7164) PCIe DVB-T Card from DigitalNow.

Will be posting back how this ends up working with the DVBLogic software. The software looks very good, and if it lives up to this during demo period. I will be the first to lay down money for a license to use it on Windows.

7164-small

 

False Advertising

I have to admit I really dislike it when anyone advertises something and things don’t appear as they seem.

Got an email just now from Harris Technology about some specials, and saw the NUC advertised. Price looks awesome for the model mentioned. But of course when you click it the webpage clearly shows this is for a different model.

Shame on you Harris Technology. I hate when I come across this false advertising. Yes the model numbers are significant, so perhaps you should be changing any graphics you use from Intel to reflect the true model being sold on special.

Below is the screen grabs that will show my complaint.

20160314_ht-com-au_deal_email

20160314_ht-com-au_NUC5PGYH

 

Commvault Pre and Post Processes

This week saw an interesting condition identified. As always I absolutely love a good challenge. Was happy to identify cause and come up with possible solutions.

In Commvault product you can associate scripts to perform Pre/Post operations. These happen in various stages of a backup for example.

Had a user indicate to me that they were having problems using a script to perform some such options. The script written was working fine when ran manually but when ran with Commvault would cause job failure due to exit/return code 1.

Asked for a copy of the scripts being used, and asked to see how it was being implemented. Immediately identified that they would define script in GUI and parse 2 arguments along with it.

Below is a snippet from the script in question. We can see script during execution checks if it has 2 options/arguments parsed and if so continues, however, as we can see if it doesn’t equal 2 it will exit 1.

# Validating Parameters
if [ $# -ne 2 ]; then
  echo "Usage `basename $0` <PRE|POST> "
  exit 1
fi

Knowing this part of the product I immediately see a problem with this, as Pre and Post processes when executed will parse your options defined, but you also get some additional hidden options parsed. Click title below to see documentation;

As such when this script is being executed with the 2 options/arguments, it is actually getting greater then 2, thus hits the code block above and does an exit 1. Thus producing the failure of the job as expected.

Solutions are;

  1. Fix up the code block in the script to account for the fact that the script needs at least 2 options (and will exceed 2).
  2. Write a wrapper script that will call the real script with only 2 options you want parsed. Thus not parsing the additional ones from Commvault.
    #!/bin/sh
    # wrapper-script
    /path/to/real-script.sh $1 $2
    exit 0
    
  3. Found an undocumented feature that you can parse an argument/option called “/suppress” to Pre/Post backup scripts as defined in GUI that will suppress the Commvault additional ones from coming into play. Note, doesn’t appear to work with Restore Pre/Post process.

Highway Thru Hell

I got watching Highway Thru Hell on Netflix. Soon after I started to watch this show I was hooked. Have noticed that it has a number of further seasons, however Netflix only has up to Season 2.

Really looking forward to seeing Season 3, as I want to know how some things unfold. Season 2 left us wanting more.

20160312_highway_thru_hell